Suche Entstörkondensator für die Steuerung eines Gasfeuerautomaten via Arduino nano

VikVik Member
bearbeitet 6. September in Sonstige Themen

Guten Tag.
Suche gerade im Conradshop einen entstörkondensator für mein Projekt.

Zum Projekt: Ein Gasfeuerungsautomat mit Zündtrafo. Der Gasfeuerungsautomat wird von einer Arduino nano gesteuert.

Zum Problem: Beim Zünden geht eine Induktion zurück die das Arduino Modul stört und das Modul hängen bleibt.

Frage: Kann man die Induktion an dem Zündtrafo oder Gasfeuerungsautomaten entstören? Wenn ja, mit welchem Kondensator?

Gruß Knaus

Antworten

  • VikVik Member

    Fotos


  • ChristianChristian Administrator admin

    Hallo @Vik, interessantes Problem, schauen wir uns an!

  • goatygoaty Moderator mod

    Und du bist sicher, daß das nicht zu Problemen führen kann bei Fehlfunktion des "Nano" ?
    Bitte paß auf, daß nichts passiert.

    Du mußt die Versorgung und die Ein-/Ausgänge des Nano entsprechend puffern und schützen, daß keine Störungen auf die Versorgungsleitung kommen oder Überspannung an Ein-/Ausgängen anliegen kann.

    Versorgungsspannung (5V/3,3V) kann man filtern mit Spule und Kombination verschiedener Kondensatoren (Keramik und Elektrolyt).
    Ein-/Ausgänge kann man mit Schutzdioden gegen Überspannung absichern.
    Gegen einen EMV-Puls müßte man das Ganze vermutlich dann noch schirmen (Metallgehäuse).

    Das wäre so meine laienhaften Tipps.

  • Hallo @Vik ,

    mir ist nicht ganz klar, wo die Induktion herkommen soll. Denkst Du, dass der Hochspannungstrafo in den Rest der Elektronik induziert, oder dass das Relais auf Bild2 beim "Loslassen" Energie induziert?
    Beim ersteren Fall sollte es ja reichen, den Hochspannungstrafo etwas weiter entfernt zu installieren, oder?
    Im für den 2. Fall hat man eigentlich parallel zum Delais eine Diode, die den Rückfluss verhindert. Ich sehe auf Bild2 auf der Platine eine Diode. Ist sie parallel zum Relais geschaltet? Ist sie in Ordnung?

    Lg, Leo

  • VikVik Member

    @goaty schrieb:
    Und du bist sicher, daß das nicht zu Problemen führen kann bei Fehlfunktion des "Nano" ?
    Bitte paß auf, daß nichts passiert.

    Du mußt die Versorgung und die Ein-/Ausgänge des Nano entsprechend puffern und schützen, daß keine Störungen auf die Versorgungsleitung kommen oder Überspannung an Ein-/Ausgängen anliegen kann.

    Versorgungsspannung (5V/3,3V) kann man filtern mit Spule und Kombination verschiedener Kondensatoren (Keramik und Elektrolyt).
    Ein-/Ausgänge kann man mit Schutzdioden gegen Überspannung absichern.
    Gegen einen EMV-Puls müßte man das Ganze vermutlich dann noch schirmen (Metallgehäuse).

    Das wäre so meine laienhaften Tipps.

    Hallo goaty.

    Alles Beschriebende schon gemacht.
    Leider ohne Erfolg.

  • goatygoaty Moderator mod
    bearbeitet 6. September

    Vielleicht zeigst du mal ein Foto vom Aufbau und ggf einen Schaltplan, dann kann man u.U. noch was empfehlen.

    Außerdem ist mir nicht klar was "in Störung" beim Arduino Nano genau bedeuten soll.
    Wie ist der Nano denn mit dem Honeywell Gasfeuerungsautomat verbunden, der hat doch gar keinen Steuereingang ?

  • VikVik Member

    @leo_s_conrad schrieb:
    Hallo @Vik ,

    mir ist nicht ganz klar, wo die Induktion herkommen soll. Denkst Du, dass der Hochspannungstrafo in den Rest der Elektronik induziert, oder dass das Relais auf Bild2 beim "Loslassen" Energie induziert?
    Beim ersteren Fall sollte es ja reichen, den Hochspannungstrafo etwas weiter entfernt zu installieren, oder?
    Im für den 2. Fall hat man eigentlich parallel zum Delais eine Diode, die den Rückfluss verhindert. Ich sehe auf Bild2 auf der Platine eine Diode. Ist sie parallel zum Relais geschaltet? Ist sie in Ordnung?

    Lg, Leo

    Hallo Leo,

    Den Gasfeuerungsautomat mit dem Zündtrafo im Nebenzimmer ganz normal über über die Steckdose angeschlossen.
    Nach der Zündung ist Nano wieder in Störung gegangen. Gasfeuerungsautomat ohne Zündtrafo schalter sauber und nano läuft ohne Probleme.
    Sobald es zündet ist Feierabend.

  • VikVik Member

    @goaty schrieb:
    Vielleicht zeigst du mal ein Foto vom Aufbau und ggf einen Schaltplan, dann kann man u.U. noch was empfehlen.

    Außerdem ist mir nicht klar was "in Störung" beim Arduino Nano genau bedeuten soll.
    Wie ist der Nano denn mit dem Honeywell Gasfeuerungsautomat verbunden, der hat doch gar keinen Steuereingang ?

    Nano gibt an das Feuerungsautomat durch einen Relais Strom.
    Das Feuerungsautomat zündet mit dem Zündungstrafo die Flamme. .....
    Darf ich einen Link zufügen von dem was ich nachbaue?

  • goatygoaty Moderator mod

    Ach so, du schaltest den Gasfeuerungsautomat per Relais.
    Das sollte ja erstmal nix machen. Wenn Arduino schön weit weg ist, dann könntest du hochstens über die Stromversorgung was abbekommen oder die fehlende Freilaufdiode von Relais, aber da wäre keine Störung sondern Arduino tot.

    Klar kannst du hier Link posten.

  • VikVik Member

    https://hobbybrauer.de/modules.php?name=eBoard&file=viewthread&tid=6408

    An Stelle An/Aus Knopfes, Relais meiner Arduino.

  • goatygoaty Moderator mod
    bearbeitet 6. September

    Wie gesagt, an dem K1 im Schaltbild

    Muß parallel eine Freilaufdiode und du kannst so ein Relais auch nicht direkt mit Arduino ansteuern !

    P.S. Wann gibts die erste Halbe ?

  • VikVik Member

    Ist zum schalten vebaut

  • goatygoaty Moderator mod
    bearbeitet 6. September

    Hm. Und die 12,5mA Strom für das SSR hat sauber 5Volt ? Nicht daß die 5V zusammenbricht aus irgendeinem Grund.
    Sieht alles gut aus. Ich denke der Arduino kriegt vielleicht einen Brown-Out, weil die Versorgung zusammenbricht ?
    Sonst fällt mir leider nix mehr ein. Sorry.

    Oder vielleicht mal mit einem Netzfilter probieren, vor die Gerätschaften getrennt vom Arduino setzen.
    Sowas vielleicht: https://www.conrad.de/de/p/yunpen-yg06t5-entstoerfilter-250-v-ac-6-a-0-7-mh-l-x-b-x-h-68-x-55-x-25-mm-1-st-521337.html

  • Hallo @Vik ,

    um Probleme mit der Stromversorgung auszuschließen, könntest Du den Arduino ja mal probeweise mit einer Power Bank betreiben. Falls das Problem wirklich auf der Signalseite liegt, könnte Man vielleicht mit einem Optokoppler arbeiten.

    Lg, Leo

Anmelden oder Registrieren, um zu kommentieren.