Bildschirm bleibt schwarz nach Rechnerstart

habe einen PC-Bauvorschlag des c’t-Magazins „der optimale PC 2020“ aus c't 24/2019 umgesetzt. Regelmäßig startet der Monitor nicht nach Einschalten des PC. Erst nach hartem Ausschalten und erneutem Einschalten des Rechners erwacht der Monitor zum Leben. Verbaut sind ein Mainboard MSI B450M Mortar MAX, AMD Ryzen 5 3400G, Kingston A2000 NVMe PCIe SSD 1TB, 32 GByte Arbeitsspeicher. Auf dem PC läuft ein Xubuntu 20.4.3 LTS. Zum Testen habe ich bereits Netzteil, Monitor und Videokabel getauscht - ohne Erfolg.

Hat jemand eine Ideee ?

Beste Grüße
Paul

Getaggt:

Beste Antworten

  • Marc_ConradMarc_Conrad Moderator moderator
    Antwort ✓

    Hallo @Paul4711

    als nächstes könntest du den Rechner mal mit nur einem RAM Riegel starten. (und dabei mal alle vier durchtesten.)
    Ich denke eine Ersatz-Grafikkarte hast du nicht vor Ort? Das wäre dann der nächste Part der getestet werden muss. Du nutzt ja denke ich den internen Grafikanschluss des Mainboards? Beide Anschlüsse getestet?

    Das Bios kenne ich leider nicht auswendig. Eventuell gibt es dort noch eine Einstellung, bei der du ihm sagen musst: "Nutze die interne Grafikeinheit."

    Viele Grüße
    Marc

  • Paul4711Paul4711 Member
    Antwort ✓

    Hallo Leo,

    die Chargennummern der beiden RAMs sind identisch. Habe inzwischen ein BIOS-Update bewerkstelligt. Der Einfachheit halber bin ich der Empfehlung der Fehlermeldung gefolgt und habe DIMMA1 nach DIMMB2 gesteckt: Keine Fehlermeldung mehr - bisher 20 Boots ohne BlackScreen !
    Das Problem scheint gelöst zu sein. Danke an Alle !!!

    Beste Grüße
    Paul

  • Kriz_conradKriz_conrad Moderator moderator
    Antwort ✓

    Ich würde hier gerne noch etwas nachtragen, bestimmt für den ein oder anderen Suchenden interessant, falls es mal nicht am Ram liegt bzw. ein weiterer Ausschlussgrund welcher schnell kontrolliert ist.
    Ein weiterer Grund könnte sein, dass das Eingangssignal nicht korrekt erkannt wird. Eine ungünstige Kombination zwischen Mainboard, Grafikkarte und Monitor. Bei den meisten Monitoren wird das Eingangssignal automatisch und korrekt erkannt, entsprechend ist beim Monitor in den Settings der Eingang standardmäßig auf "automatisch" eingestellt.
    Hier könnte man das Signal aber auch manuell festlegen, z.B. HDMI, oder DVI etc. und so dem System eindeutig sagen, welches Signal kommt.

Antworten

  • Marc_ConradMarc_Conrad Moderator moderator
    Antwort ✓

    Hallo @Paul4711

    als nächstes könntest du den Rechner mal mit nur einem RAM Riegel starten. (und dabei mal alle vier durchtesten.)
    Ich denke eine Ersatz-Grafikkarte hast du nicht vor Ort? Das wäre dann der nächste Part der getestet werden muss. Du nutzt ja denke ich den internen Grafikanschluss des Mainboards? Beide Anschlüsse getestet?

    Das Bios kenne ich leider nicht auswendig. Eventuell gibt es dort noch eine Einstellung, bei der du ihm sagen musst: "Nutze die interne Grafikeinheit."

    Viele Grüße
    Marc

  • Paul4711Paul4711 Member
    bearbeitet 24. Februar

    Hallo Marc,

    Danke für die Info ! Betrieb bis jetzt zwei 16 GB RAM-Riegel im vier RAM-Slots - Mainboard. Fand im Manual folgende Passage:
    Important
    Always insert memory modules in the DIMMA2 slot first.

    Der PC läuft jetzt testweise mit einem 16 GB RAM-Riegel in DIMMA2. Bereits 10 Rechnerstarts sind heute ohne "Black Screen" geglückt. Im Keller fand ich eine alte PCI-Grafikkarte - im Bedarfsfall kommt sie zum Einsatz

    Beste Grüße
    Paul

    ScreenShot Manual:

  • leo_s_conradleo_s_conrad Moderator moderator

    Hallo @Paul4711 ,

    also wenn er jetzt gut mit der internen Garfikkarte läuft, kannst Du die PCI Karte im Keller lassen. Hast Du einen Ram-Riegel als Defekt feststellen können? Sind die Ram-Riegel eigentlich identisch? Also gleicher Hersteller, gleiche Chargennummer?

    Übrigens thumbs up für Xubuntu! Ich bin mit Kubuntu unterwegs.
    Lg, Leo

  • Hallo Leo,

    die beiden RAM-Riegel stammen aus einem 32 GB-Bundle - und sind somit identisch. Meine Planung sieht aus wie folgt:

    • Morgen Mittag erreiche ich 20 Rechnerstarts. Sollten bis dahin keine "Black Screens" auftauchen, wechsle ich den RAM-Riegel in DIMMA2.
    • Anschließend erneuter Test mit 20 Rechnerstarts.
    • Bei Erfolg stecke ich den zweiten Riegel in DIMMB2 und teste erneut mit 20 Boots.

    Beste Grüße
    Paul

  • leo_s_conradleo_s_conrad Moderator moderator

    Hallo @Paul4711 ,
    Es gehören ja immer zwei Slots zusammen. Die beiden Riegel können dann im dual-channel modus arbeiten. Du solltest also den zweiten Ram in den DIMMA1 Sockel stecken, statt in DIMMB2.

    Lg, Leo

  • Paul4711Paul4711 Member

    Habe die RAM-Riegel in die Slots DIMMA1 und DIMMA2 gesteckt. Beim Booten kommt folgende Fehlermeldung:

    Der Rechner bootet und läuft normal.
    Ein Blick ins BIOS zeigt Folgendes:

    Beste Grüße
    Paul

  • leo_s_conradleo_s_conrad Moderator moderator

    HAllo @Paul4711 ,
    OK, dann habe ich das in der Anleitung falsch interpretiert und es gehören (für den dual-channel Modus) wohl doch 1A2 und 1B2 zusammen. Läuft es auch, wenn Du den Ram entsprechend von 1A1 nach 1B2 umsteckst? Oder war das die Ausgangslage, in der der Bildschirm manchmal schwarz wurde?

    Lg, Leo

  • Paul4711Paul4711 Member

    Hallo Leo,

    Oder war das die Ausgangslage, in der der Bildschirm manchmal schwarz wurde?

    Die Kombination DIMMA2 DIMMB2 war exakt die Ausgangslage. Denkst Du, es wäre unbedenklich für die Hardware verschiedene Kombination einfach zu testen ?

    Beste Grüße
    Paul

  • leo_s_conradleo_s_conrad Moderator moderator

    Hallo @Paul4711 ,
    der Hardware wird das nicht ausmachen, verschienede Kombinationen zu testen. Allerdings ist natürlich immer nur in den zwei zusammengehörigen Sockeln Dual-Channel Betrieb möglich.
    Bitte vergleich mal die Chargennummer der beiden Rams. Sind sie wirklich gleich? Weißt Du noch welcher Ram anfangs in welchem Sockel steckte? Macht es einen UNterschied, welche Ram in welchem Sockel steckt (also wenn Du DimmA2 und DimmB2 besetzt)?

    Lg, Leo

  • Paul4711Paul4711 Member
    Antwort ✓

    Hallo Leo,

    die Chargennummern der beiden RAMs sind identisch. Habe inzwischen ein BIOS-Update bewerkstelligt. Der Einfachheit halber bin ich der Empfehlung der Fehlermeldung gefolgt und habe DIMMA1 nach DIMMB2 gesteckt: Keine Fehlermeldung mehr - bisher 20 Boots ohne BlackScreen !
    Das Problem scheint gelöst zu sein. Danke an Alle !!!

    Beste Grüße
    Paul

  • Paul4711Paul4711 Member

    Hallo Leo,

    die Chargennummern der beiden RAMs sind identisch. Habe inzwischen ein BIOS-Update bewerkstelligt. Der Einfachheit halber bin ich der Empfehlung der Fehlermeldung gefolgt und habe DIMMA1 nach DIMMB2 gesteckt: Keine Fehlermeldung mehr - bisher 20 Boots ohne BlackScreen !
    Das Problem scheint gelöst zu sein. Danke an Alle !!!

    Beste Grüße
    Paul

  • Kriz_conradKriz_conrad Moderator moderator
    Antwort ✓

    Ich würde hier gerne noch etwas nachtragen, bestimmt für den ein oder anderen Suchenden interessant, falls es mal nicht am Ram liegt bzw. ein weiterer Ausschlussgrund welcher schnell kontrolliert ist.
    Ein weiterer Grund könnte sein, dass das Eingangssignal nicht korrekt erkannt wird. Eine ungünstige Kombination zwischen Mainboard, Grafikkarte und Monitor. Bei den meisten Monitoren wird das Eingangssignal automatisch und korrekt erkannt, entsprechend ist beim Monitor in den Settings der Eingang standardmäßig auf "automatisch" eingestellt.
    Hier könnte man das Signal aber auch manuell festlegen, z.B. HDMI, oder DVI etc. und so dem System eindeutig sagen, welches Signal kommt.

Anmelden oder Registrieren, um zu kommentieren.